Exchange: Why am I being told to update my browser when I'm using the latest version of Internet Explorer?

If you are using Internet Explorer 11, but you're being told that you need to update your browser, it is likely that your browser has the ‘Compatibility View’ enabled.

The ‘Compatibility View’ tells your browser to use an old version of the rendering engine to be compatible with older websites that require Internet Explorer 9 (IE9).


To change the Compatibility View settings:

  1. Open Internet Explorer
  2. Press Alt key to display the Menu bar
  3. Click on 'Tools' --> 'Compatibility View settings'
    Image 
  4. Make sure "betfair.com" is not on the 'Websites you've added to Compatibility View' list
  5. Disable 'Display intranet sites in Compatibility View'
    Image


Microsoft has a help page describing how to enable/disable the 'Compatibility View'.

We also recommend using Google Chrome or Mozilla Firefox for a faster and more stable experience.